Aftersales Online System

Metanavigation


Technical requirements


In order to use the Aftersales Online System (AOS), it is necessary to meet the following technical prerequisites (status: 01.02.2016).

1. Network/internet connection

  • Internet access with a download bandwidth of at least 4 MBit/s and an upload bandwidth of at least 400 KBit/s is required.
  • For carrying out vehicle diagnoses, the relevant workshop systems must be connected by a LAN cable with a bandwidth of at least 100 MBit/s.
  • For programming, a LAN cable with a bandwidth of at least 100 MBit/s is required per programming session. ISSS Next and ISID Next require a 1 GBit/s connection at the Gigabit switch, in order to avoid performance bottlenecks and programming aborts.
  • For optimum performance, a maximum latency of 100 ms to the AOS server in Munich is recommended.
  • It must be ensured that the IP address does not change during the session.

2. Hardware

A device that meets the following prerequisites is needed for installing and using the BMW Service Tools:

  • The processor must be at least a Core 2 Duo or an Intel Core i3 (2.2GHz)
  • At least 4 GB main memory
  • At least 160 GB free hard disk space
  • A monitor with a DVI, HDMI or display port connection and a display screen resolution of at least: 1366x768, 1280x800, 1280x1024 (depending on display screen format)
  • Optical drives: DVD drive or Blu-ray drive (incl. support for dual-layer media and DVD/CD support), support for BD XL
  • Interfaces: USB 2.0 / optionally RS-232 (e.g. for KeyReader)
  • Network
    • 1x 1 GBit LAN connection
    • Auto Uplink (Auto MDI/MDI-X)
    • IEEE 802.3, IEEE 802.3ab
    • Alternatively WLAN (300 MBit)
    • Network connection to connect to the internet
  • Connectivity to a suitable Vehicle Communication Interface
  • Input devices: Keyboard and mouse

For in-vehicle diagnosis and programming you will need one of the following Vehicle Communication Interfaces (VCI):

  • ICOM (recommended by BMW)
    • An additional network connection is required for connecting the ICOM to the computer.
  • Pass-through tool (PTD), which must be compatible with SAE J2534 (e.g. from the manufacturers Drew Technologies, I+ME ACTIA)
    • Depending on the manufacturer's specifications, a free interface (e.g. RS232 or USB) may be required to connect the PTD.
    • You will require the PTD manufacturer's proprietary driver, installed according to the AOS User's Guide.
    • Before purchasing a computer/operating system please also check the technical prerequisites of your PTD manufacturer (e.g. there are some PTDs that are not compatible with Windows 7 Professional © 64-bit).
    • PTDs are not allowed to be activated via Bluetooth.

3. Operating system & runtime environments

One of the following operating systems is required in order to use the Aftersales Online System (AOS):

  • Microsoft Windows 7 Professional/Enterprise © (32-bit) with Service Pack 1 or
  • Microsoft Windows 7 Professional/Enterprise © (64-bit) with Service Pack 1 or
  • Microsoft Windows 8.1 Professional/Enterprise © (64-bit).

In addition to the operating system, the following runtime environments must be installed before you can use the applications:

JAVA©- The following requirements must be met:

  • Compatibility with the operating system you are using (e.g. Java© 64-bit with Windows 7 Professional © 64-bit)
  • You will need one of the following Java© versions depending on your operating system:
    • Java© 32-bit with runtime environment JRE 7 or higher.
    • Java© 64-bit with runtime environment JRE 7 or higher.

This compatibility with the operating system must be observed when carrying out the Java© download.

When using a PTD:

  • Compatibility with the pass-through tool device driver according to the manufacturer's specifications (e.g. 32-bit device driver for 32-bit operating system or 64-bit device driver for 64-bit operating system).
  • It is essential to install Java© 32-bit with runtime environment JRE 7 (Java© 32-bit must also be installed on a 64-bit operating system).
  • Java© 64-bit and Java© 32-bit runtime environments must not be installed in parallel on the computer, but just Java© 32-bit exclusively.
  • To avoid incompatibilities, we recommend deactivating the automatic JAVA© update function (e.g. when using Java© 32-bit with Windows 7 Professional © 64-bit).

Microsoft .NET - The following requirements must be met:

4. Browser

The Internet Explorer © 11 browser is required.

5. Installation and configuration settings

Please see the user guide for additional information, such as the additional software required and the configuration settings in the operating system or browser. Following successful registration you will find the user guide in the general download area or on the information pages for the respective application.